what fuel pump do you use?

megadesertdiesel

Well-Known Member
i have a MSD pump and it is a couple years old now. thinking i should replace it before next dune season. what pump is everyone using?
 
I used a JEGs pump, which is actually a reboxed Walbro, but for cheaper. Ive always heard good things about Walbros.
 
im running the MSD one from Weller...

I would think it should last you more than a couple years, especially since it hasn't seen that much use yet. How many times have you had that car out?

G-
 
im running the MSD one from Weller...

I would think it should last you more than a couple years, especially since it hasn't seen that much use yet. How many times have you had that car out?

G-

3 trips with it in the RZR1 form but i used it with the stock poolaris motor for a year before that.

i was just concerned my fuel pressure was bouncing between 40 and 50psi just after the pump at my gauge. and the fuel stream is aerated like a faucet when i disconnect if from the fuel rail and pump it into a gas can.

i have been driving it on the street the last two days just to make sure its all good for this weekend in the cinders. drove to a friends house in east Mesa from my house yesterday. the looks i got where priceless. haha street legal rocks!!!
 
It should be maintaining fuel pressure better than that IMO. Are you using an aftermarket fuel pressure reg, or the Stock R1 regulator?
 
Yeah.. jumping from 40 to 50, and spitting air sounds like you are having some sort of an issue. It could be the pump, plugged filter, or possibly your pick up inside the tank is pulling in air or something. How old is your fuel cell foam? They say that stuff only lasts a couple years before it starts breaking down and clogging up the fuel filter.. so it might be time to replace the foam and filter.. not sure.

Good luck.. Headed to the cinders this weekend eh.. that should be fun. And nice and cool. You going to run your paddles? I wouldn't, unless you want to make them smaller. We took our old VW rail up there a long time ago and lost about a 1/4" of paddle length from one weekend up there.. just fyi.

g-
 
Yeah.. jumping from 40 to 50, and spitting air sounds like you are having some sort of an issue. It could be the pump, plugged filter, or possibly your pick up inside the tank is pulling in air or something. How old is your fuel cell foam? They say that stuff only lasts a couple years before it starts breaking down and clogging up the fuel filter.. so it might be time to replace the foam and filter.. not sure.

Good luck.. Headed to the cinders this weekend eh.. that should be fun. And nice and cool. You going to run your paddles? I wouldn't, unless you want to make them smaller. We took our old VW rail up there a long time ago and lost about a 1/4" of paddle length from one weekend up there.. just fyi.

g-

i removed the foam when i swapped motors and i made sure to put a brass fitting on the end of the pickup to kepp it on the bottom. i also replaced my pre and post filters. but i have not removed the fill neck at the cell to look inside, thats next. i will also replace the gauge today with a liquid filled one today and see if i have a bad gauge.

yeah i bought some 26x12x12 16 paddle "far east" brand paddles from CL for $75 a pair new and mounted them on my sand wheels for the cinders. i should be able to climb anything i want and not worry about flats and tearing up expensive paddles.
 
Its hard to trust inline fuel pressure gauges...my buddy went thru about 6 of them until he got one that worked right:eek:
 
Are you using inline gauge or do you have on right on your regulator, mine screws right into my regulator. My fuel pump is an Aeromtive.
 
i have an inline brass tee with an fitting threaded into it and a gauge on the bullhead of the tee. no regulator due to the stock fuel rail has one on the return side.
 
i have an inline brass tee with an fitting threaded into it and a gauge on the bullhead of the tee. no regulator due to the stock fuel rail has one on the return side.

What year R1 motor did you use?:confused: Hopefully I can do the same...I havent even look at any of the plumbing yet
 
What year R1 motor did you use?:confused: Hopefully I can do the same...I havent even look at any of the plumbing yet

2006. i swapped gauges last night and still doing it and my fuel suction at the cell is all good. dunno. i am going to check out the stock regulator at the rail tonight.
 
I am pretty sure the 07-08's don't have a regulator. There is only one inlet on the fuel rail, nothing going back to the tank, so they have to run an external regulator like we did on ours.

G-
 
Inline gauge? As opposed to......?

Any fuel pressure gauge is mounted "inline". A pressure gauge can be mounted right off the outlet of the pump, before or after the filter (as long as the filter is after the pump), anywhere on the feed line, anywhere on the fuel rail, or on the gauge port on the regulator. Pressure is pressure.

I'd recommend a Walbro. They are great pumps.

LSRGreg is right. The 07+ have a dead end system; the regulator is in the tank/on the pump.
 

Members online

No members online now.

Forum statistics

Threads
17,299
Messages
179,400
Members
12,147
Latest member
Williamobjem
Back
Top